Get in touch
Back
Downtime

Hosted Sites, https://www.dthcustomartdesign.co.uk, https://www.whitehorsepsychology.co.uk, and 1 other service are down

Started 1 Dec at 11:06am GMT, resolved 1 Dec at 11:11am GMT.

Hosted Sites https://www.dthcustomartdesign.co.uk https://www.whitehorsepsychology.co.uk
Resolved

Hosted Sites, https://www.dthcustomartdesign.co.uk, and https://www.whitehorsepsychology.co.uk recovered.

Posted 1 Dec at 11:11am GMT.
Created

Hosted Sites, https://www.dthcustomartdesign.co.uk, and https://www.whitehorsepsychology.co.uk went down.

Posted 1 Dec at 11:06am GMT.